It is currently Sun Dec 17, 2017 2:04 pm

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Image Manager no thumbs
PostPosted: Sat Mar 01, 2014 5:57 pm 
Offline

Joined: Sat Mar 01, 2014 5:52 pm
Posts: 5
Hi Can anyone tell me how to get the thumbs to show in image manager ? (everything else about the wonderful plug in works fine)
Attahed is an image of what I see.


Attachments:
image manager.JPG
image manager.JPG [ 74.08 KiB | Viewed 7160 times ]
Top
 Profile  
 
 Post subject: Image Manager no thumbs
PostPosted: Sat Mar 01, 2014 5:57 pm 
Top  
PostPosted: Mon Mar 03, 2014 12:04 pm 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
Hmm, that is strange.
What Joomla version are you using? On what OS do you run it?
What happens if you add menu item of Image Manager type?
Do you have the same problem when accessing Image Manager from front end?

It might be some path issue, probably. I'm not sure.

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
PostPosted: Mon Mar 03, 2014 12:42 pm 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
viewtopic.php?f=34&t=957&p=3501#p3501
Here is a similar issue, don't know if suggested solution worked as the user never replayed.

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
PostPosted: Mon Mar 03, 2014 2:48 pm 
Offline

Joined: Sat Mar 01, 2014 5:52 pm
Posts: 5
hi again, Thank you for your response.

My root images directory and /images/albums directory are both 755

Answers to some of your questions

I am using Joomla 2.5.18, and it is hosted on an Linux OS Apache 2 and php version is 5.3.3
I am the only user.

When I upload an image via Joomla interface all works fine and the image is also seen on the front end (as are all of the others), http://www.realitytherapy-europe.org/index.php/ct-menu-item-17/31-articles/231-article-19 .

But in the image manager the broken icon thumb is the same as all other others.

I might try uninstalling / reinstalling the plugin to see what difference that makes.

UPDATE: I have uninstalled/reinstalled but with no difference. - the add/delete options in the image manager work fine, so all seems okay except for the image thumbs.


Top
 Profile  
 
PostPosted: Mon Mar 03, 2014 5:31 pm 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
No need to uninstall/install the component.

I tested here on my Virtual machine, I did not have any problems with Image Manager.

Can you check if there is any thumbnail in "administrator/components/com_admirorgallery/assets/thumbs"?
If thumbnails are missing, check you server error log (PHP and Apache) there should be an error that should give us some more clue on what seems to be the problem.

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
 Post subject: Re: Image Manager no thumbs
PostPosted: Mon Mar 03, 2014 5:31 pm 
Top  
PostPosted: Wed Mar 05, 2014 3:48 pm 
Offline

Joined: Sat Mar 01, 2014 5:52 pm
Posts: 5
Hi again,

There are no thumbs in the "administrator/components/com_admirorgallery/assets" directory.

I do not know how to access the server error log (PHP and Apache)


Top
 Profile  
 
PostPosted: Thu Mar 06, 2014 12:13 pm 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
Do you, maybe have some extra protection for administrator folder that could prevent script from outside it to access files that are located in administrator folder?

Anyhow, in file administrator\components\com_admirorgallery\views\imagemanager\scripts\imgManager-render-folder.php line: 371:
Code:
        agHelper::ag_createThumb(JPATH_SITE . $ag_itemURL . $value, $thumbsFolderPhysicalPath . DS . $value, 145, 80, "none");

From what you said this function fails to create the thumbnails.
For further investigation, you could check \plugins\content\admirorgallery\admirorgallery\classes\agHelper.php line 333 and see why does it fail to create the thumbnails. Just remove @ from each line in this function, and open Image Manager, you should see a Notice or Error at the top of the page that will give more info.
Just for reference, @ suppresses any error in PHP.

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
PostPosted: Thu Mar 06, 2014 3:06 pm 
Offline

Joined: Sat Mar 01, 2014 5:52 pm
Posts: 5
First of all thank you for your time spent on this - I really appreciate it.

The imgManager-render-folder.php line: 371: agHelper::ag_createThumb(JPATH_SITE . $ag_itemURL . $value, $thumbsFolderPhysicalPath . DS . $value, 145, 80, "none"); is the same as your posting.

I am not sure which @ symbols on which lines I need to remove - I removed them from lines 343, 345, 347, but there is no error message in the image galery. Maybe I am removing the wrong things - should I continue down and remove all @ symbols (if so, up to which line) ? Below is a capture of my coding.


Attachments:
php.JPG
php.JPG [ 81.76 KiB | Viewed 7136 times ]
Top
 Profile  
 
PostPosted: Sat Mar 08, 2014 12:18 am 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
Is there a way to let me access your admin and check this issue?

In general remove all "@" in that function, to see what fails.
You should check your Hosting control panel, for Error log, that would help.

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
 Post subject: Re: Image Manager no thumbs
PostPosted: Sat Mar 08, 2014 12:18 am 
Top  
PostPosted: Tue Mar 11, 2014 8:17 pm 
Offline

Joined: Sat Mar 01, 2014 5:52 pm
Posts: 5
Thank you Nicola for all your help.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

 


All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

This is the official Admiror Joomla! Community Forum. You are welcome to join the Admiror Joomla! Community. All Admiror Joomla! Extensions Users, Joomla! Developers, PHP or mySQL Developers are welcome to support & contribute to Admiror Joomla! Projects.

Joomla! is a free and open source content management system (CMS) for publishing content on the World Wide Web and intranets. With a vibrant volunteer community, user-friendly features and plenty of power, Joomla is perfect for your website!

Joomla! is written in PHP, uses object-oriented programming (OOP) techniques and software patterns, stores data in a MySQL database, and includes features such as page caching, RSS feeds, printable versions of pages, news flashes, blogs, polls, search, and support for language internationalization.

Joomla! is the property of Open Source Matters, Inc. All rights reserved. Read more about Joomla! at http://www.joomla.org/.


Protected by Anti-Spam ACP Powered by phpBB® Forum Software © phpBB Group