It is currently Tue Dec 12, 2017 10:39 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Jan 24, 2014 12:57 pm 
Offline

Joined: Thu Jan 23, 2014 10:10 pm
Posts: 5
I am using Albums for my picture gallery. Template: Classic. Popup: Fancybox.
I added captions to some of my pictures and discovered that the box around the picture (that should change its color with the parameter "Highlite Color") disappeared. The pictures without caption still have the box. I erased the caption of one of the pictures and the box came back.
Is this intended, or am I missing something?

TIA!


Top
 Profile  
 
 Post subject: Adding caption to picture makes highlite effect disappear
PostPosted: Fri Jan 24, 2014 12:57 pm 
Top  
PostPosted: Fri Jan 24, 2014 3:01 pm 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
That is strange, I cannot reproduce that on my side. Can you post a link to your site or post a screen shot of the problem? Link would be more helpful :)

It might be that some CSS style is messing the display.

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
PostPosted: Fri Jan 24, 2014 6:41 pm 
Offline

Joined: Thu Jan 23, 2014 10:10 pm
Posts: 5
Of course I can.
Although the site is still not 100% ready and it's in Hebrew.
You can see the PicGallery here. The album I am working on now is the third from left (with me sitting on a chair). Within that album, the first line have caption, and the lower pic does not. Only on the lower one there's the box and the "Highlite" effect.

Thank you in advance for your reply.


Top
 Profile  
 
PostPosted: Sat Jan 25, 2014 5:18 pm 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
It looks like something in your description is braking the output HTML code.
It might be the " (quotation). So the class for <img> tag gets corrupted. You can see that if you inspect HTML code of the images that has no hover effect.

To fix this, there is two solutions: remove " from your captions (this is not best solution) or edit plugins\content\admirorgallery\admirorgallery\classes\agGallery.php (I recommend this)
Find:
Code:
function writePopupThumb($image) {

and change this line:
Code:
$html.='<a href="' . $this->imagesFolderPath . $image . '" title="' . htmlspecialchars($this->descArray[$image], ENT_QUOTES, "UTF-8") . '" class="' . $this->popupEngine->className . '" rel="' . $this->popupEngine->rel . '" ' . $this->popupEngine->customAttr . ' target="_blank">' . $this->writeNewImageTag($image) . '<img src="' . $this->sitePath . PLUGIN_BASE_PATH . 'thumbs/' . $this->imagesFolderName . '/' . $image . '" alt="' . strip_tags($this->descArray[$image]) . '" class="ag_imageThumb"></a>';

to this
Code:
$html.='<a href="' . $this->imagesFolderPath . $image . '" title="' . htmlspecialchars($this->descArray[$image], ENT_QUOTES, "UTF-8") . '" class="' . $this->popupEngine->className . '" rel="' . $this->popupEngine->rel . '" ' . $this->popupEngine->customAttr . ' target="_blank">' . $this->writeNewImageTag($image) . '<img src="' . $this->sitePath . PLUGIN_BASE_PATH . 'thumbs/' . $this->imagesFolderName . '/' . $image . '" alt="' . htmlspecialchars(strip_tags($this->descArray[$image])) . '" class="ag_imageThumb"></a>';


Let me know if this fixes your problem, so I could update the code :)

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
PostPosted: Sat Jan 25, 2014 6:15 pm 
Offline

Joined: Thu Jan 23, 2014 10:10 pm
Posts: 5
"Like a glove!!" :D :D
Thank you !!


Top
 Profile  
 
 Post subject: Re: Adding caption to picture makes highlite effect disappea
PostPosted: Sat Jan 25, 2014 6:15 pm 
Top  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

 


All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

This is the official Admiror Joomla! Community Forum. You are welcome to join the Admiror Joomla! Community. All Admiror Joomla! Extensions Users, Joomla! Developers, PHP or mySQL Developers are welcome to support & contribute to Admiror Joomla! Projects.

Joomla! is a free and open source content management system (CMS) for publishing content on the World Wide Web and intranets. With a vibrant volunteer community, user-friendly features and plenty of power, Joomla is perfect for your website!

Joomla! is written in PHP, uses object-oriented programming (OOP) techniques and software patterns, stores data in a MySQL database, and includes features such as page caching, RSS feeds, printable versions of pages, news flashes, blogs, polls, search, and support for language internationalization.

Joomla! is the property of Open Source Matters, Inc. All rights reserved. Read more about Joomla! at http://www.joomla.org/.


Protected by Anti-Spam ACP Powered by phpBB® Forum Software © phpBB Group