It is currently Mon Dec 18, 2017 9:07 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: AG 4.0 problem
PostPosted: Fri Sep 09, 2011 6:59 am 
Offline

Joined: Fri Sep 09, 2011 6:56 am
Posts: 1
Hello!
Installed AG 4.0 on my joomla 1.6, but have this error
Code:
Warning: require(plugins/content/AdmirorGallery/AdmirorGallery/popups/slimbox/index.php) [function.require]: failed to open stream: No such file or directory in /home/childr01/public_html/plugins/content/admirorgallery/AdmirorGallery/classes/agGallery.php on line 291

Fatal error: require() [function.require]: Failed opening required 'plugins/content/AdmirorGallery/AdmirorGallery/popups/slimbox/index.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/childr01/public_html/plugins/content/admirorgallery/AdmirorGallery/classes/agGallery.php on line 291


Also in admin part i saw warning.. umm.. about not created pathes templates and popup.

I changed rights to 777, added pathes but page with gallery is empty! Even template disapear! What can i do? Thanks.


Top
 Profile  
 
 Post subject: AG 4.0 problem
PostPosted: Fri Sep 09, 2011 6:59 am 
Top  
 Post subject: Re: AG 4.0 problem
PostPosted: Fri Sep 09, 2011 12:36 pm 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
Did you try to reinstall the plugin?
Maybe something went wrong with installation.

I will check this, maybe there is something wrong with required paths.

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
 Post subject: Re: AG 4.0 problem
PostPosted: Fri Sep 09, 2011 1:59 pm 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
Try this version, I fixed case difference in include paths and updated description :)

I develop on Windows (that's bad, I know ;) and Windows is not case sensitive when including scripts, so I missed this :)

Let me know if this helped, so we could update current release.

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
 Post subject: Re: AG 4.0 problem
PostPosted: Sat Sep 10, 2011 3:43 pm 
Offline
Contributor
Contributor
User avatar

Joined: Thu Oct 21, 2010 12:31 am
Posts: 217
Location: Essex, UK
Okay, when did AG 4.0 appear??? There's no Sub-forum for 4.0, no thread or anything...just the attachment on here!

And is 4.0 for joomla 1.6/1.7 as originally touted? does it work on 1.5 as well or just the newer versions?

Hmm?

Sam


Top
 Profile  
 
 Post subject: Re: AG 4.0 problem
PostPosted: Sun Sep 11, 2011 2:31 am 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
There is a release on the official page here : http://www.admiror-design-studio.com/en/joomla-extensions

This is just a plugin, and it is taken from 3.0.185 version that is for J1.5 version and modified to work in J1.6 and J1.7 versions.
It work only on J1.6 and J1.7 :)

The whole component requires a lot of rewrite that I just don't have the time to do :( Hope I will have some time soon.

If anyone has any experience with converting J1.5 component to J1.6 and J1.7 any help would be appreciated.

The biggest problem for now is converting JParameters to JForms and working with that :) I just can't figure that out.

This is just to fill in the gap until the whole component is finished, and to show that we made some progress :)

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
 Post subject: Re: AG 4.0 problem
PostPosted: Sun Sep 11, 2011 2:31 am 
Top  
 Post subject: Re: AG 4.0 problem
PostPosted: Sun Sep 11, 2011 10:31 am 
Offline
Contributor
Contributor
User avatar

Joined: Thu Oct 21, 2010 12:31 am
Posts: 217
Location: Essex, UK
Ah I see - I don't often bother with the "official" page as the forums are better and usually just as (or more so) up-to-date! hehe.

Plugin installed on my wip update to the seaxe website....currently on install of that I'm getting these errors:

Quote:
Warning: require(plugins/content/AdmirorGallery/AdmirorGallery/popups/slimbox/index.php) [function.require]: failed to open stream: No such file or directory in /home/sifsskhn/public_html/newseaxe/plugins/content/admirorgallery/AdmirorGallery/classes/agGallery.php on line 291

Warning: require(plugins/content/AdmirorGallery/AdmirorGallery/popups/slimbox/index.php) [function.require]: failed to open stream: No such file or directory in /home/sifsskhn/public_html/newseaxe/plugins/content/admirorgallery/AdmirorGallery/classes/agGallery.php on line 291

Fatal error: require() [function.require]: Failed opening required 'plugins/content/AdmirorGallery/AdmirorGallery/popups/slimbox/index.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/sifsskhn/public_html/newseaxe/plugins/content/admirorgallery/AdmirorGallery/classes/agGallery.php on line 291


Which fairly clearly points to it not having slimbox installed...but of course the current popups are all 1.5 only. hmmm

Thanks for the work so far and here's hoping you find the time you need! :D

Sam / Bifford


Top
 Profile  
 
 Post subject: Re: AG 4.0 problem
PostPosted: Sun Sep 11, 2011 10:34 am 
Offline
Contributor
Contributor
User avatar

Joined: Thu Oct 21, 2010 12:31 am
Posts: 217
Location: Essex, UK
and was henceforth solved :

require(plugins/content/AdmirorGallery/AdmirorGallery/popups/slimbox/index.php)

the first admirorgallery folder (the one after /content/ ) was named with all lowercase letters on my server but I saw that the lines all used a capital A and G so I altered that in my ftp program and now it's fine - no error.

So the install process of the plugin needs altering slightly to name the first AG folder using a capital A and G :D

:D

Sam / Bifford


Top
 Profile  
 
 Post subject: Re: AG 4.0 problem
PostPosted: Sun Sep 11, 2011 10:39 am 
Offline
Contributor
Contributor
User avatar

Joined: Thu Oct 21, 2010 12:31 am
Posts: 217
Location: Essex, UK
Fnar! Okay - and further to that - renaming that folder from admirorgallery to AdmirorGallery then screws up being able to access the plugin in the backend in extensions:plugins!!

I guess I need to edit a file somewhere so that the slimbox calls are directed through "admirorgallery" and not "AdmirorGallery".

Is there any way to change the AG system so capitals do not break things? If not then the slimbox calls need a very minor re-writing!!

(oh, and an AG 4.x forum is now needed! :D )

Sam.


Top
 Profile  
 
 Post subject: Re: AG 4.0 problem
PostPosted: Sun Sep 11, 2011 4:48 pm 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
Did you have problems with version from the forum, or with the version from the official site?

I think I fixed this problems in this version on the forum, but I don't have a way to test this because I use Windows :)

P.S. New forum created :)

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
 Post subject: Re: AG 4.0 problem
PostPosted: Sun Sep 11, 2011 4:48 pm 
Top  
 Post subject: Re: AG 4.0 problem
PostPosted: Sun Sep 11, 2011 4:57 pm 
Offline
Contributor
Contributor
User avatar

Joined: Thu Oct 21, 2010 12:31 am
Posts: 217
Location: Essex, UK
Vasiljevski wrote:
Did you have problems with version from the forum, or with the version from the official site?

I think I fixed this problems in this version on the forum, but I don't have a way to test this because I use Windows :)

P.S. New forum created :)


I downloaded from this thread :)

and stupidly I didn't even notice that the problem I had was the same one the original poster had lol. But yes, it's still there.

Sam


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next

 


All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

This is the official Admiror Joomla! Community Forum. You are welcome to join the Admiror Joomla! Community. All Admiror Joomla! Extensions Users, Joomla! Developers, PHP or mySQL Developers are welcome to support & contribute to Admiror Joomla! Projects.

Joomla! is a free and open source content management system (CMS) for publishing content on the World Wide Web and intranets. With a vibrant volunteer community, user-friendly features and plenty of power, Joomla is perfect for your website!

Joomla! is written in PHP, uses object-oriented programming (OOP) techniques and software patterns, stores data in a MySQL database, and includes features such as page caching, RSS feeds, printable versions of pages, news flashes, blogs, polls, search, and support for language internationalization.

Joomla! is the property of Open Source Matters, Inc. All rights reserved. Read more about Joomla! at http://www.joomla.org/.


Protected by Anti-Spam ACP Powered by phpBB® Forum Software © phpBB Group