It is currently Thu Dec 14, 2017 9:58 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Image manager issues
PostPosted: Tue Feb 19, 2013 10:00 pm 
Offline

Joined: Tue Feb 19, 2013 9:04 pm
Posts: 4
Hi all,

First off this is a great component.

My problem is with the image manager, I am getting the blank white screen when I click on the folder with my images to edit.

I read around the forums and saw that file size being to big and images names having spaces and such may cause the white blank screen.

I have since renamed all the images and brought each file size down to about 200-400 kb a piece or less.

I am still getting the blank white screen.

The problematic folders all have a lot of images 100+ and it will continue to grow as the website I have employed the use of the component is a portfolio type website.

I am however able to make the folder load with the thumbnail images if I remove half of the pictures from each folder and place them into another.
This would be a decent fix except for the fact that I need all images in one folder/ one category.

How can I fix this ?

All I need to do is be able to sort my pictures in the image manager.

I was using Rokgallery before and it was a huge pain and was extremely problematic. Admiror is my last hope for deal with large amounts of images.


Top
 Profile  
 
 Post subject: Image manager issues
PostPosted: Tue Feb 19, 2013 10:00 pm 
Top  
 Post subject: Re: Image manager issues
PostPosted: Thu Feb 21, 2013 8:51 pm 
Offline

Joined: Tue Feb 19, 2013 9:04 pm
Posts: 4
Bump,

please help


Top
 Profile  
 
 Post subject: Re: Image manager issues
PostPosted: Tue Mar 05, 2013 9:13 pm 
Offline

Joined: Tue Feb 19, 2013 9:04 pm
Posts: 4
Bump,

please help


Top
 Profile  
 
 Post subject: Re: Image manager issues
PostPosted: Wed Mar 06, 2013 12:42 am 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
Sorry, I must have overlooked your post. Sometimes I check for new post from work, and get distracted.

What are the dimensions of the images you have?

Do you have access to PHP error log? Can you check if there is any error when blank page appears?

If you have images with large resolution (1920x1080 and more) it might take your server a long time to create thumbs for all of them, and PHP script execution time, usually 30 seconds on shared hostings,expires and blank page is displayed.

I managed to reproduce you problem at my side. And can confirm that script execution time is the problem with a lot of images.

So there are two solutions:
You can add :

set_time_limit(0);
in : administrator\components\com_admirorgallery\views\imagemanager\view.html.php

Code:
    function display($tpl = null)
    {
     JToolBarHelper::title( JText::_( 'COM_ADMIRORGALLERY_IMAGE_MANAGER' ), 'imagemanager' );
          set_time_limit(0);
     parent::display($tpl);
    }

This may be a problem on shared hostings, they don't usually allow changing this value from PHP. But it's worth a shot.

The other solution is to comment out creating of thumbnails and just let images to load as they are and size them down to the thumb size.
This is the code that needs to be changed: administrator\components\com_admirorgallery\views\imagemanager\scripts\imgManager-render-folder.php
Code:
        agHelper::ag_createThumb(JPATH_SITE . $ag_itemURL . $value, $thumbsFolderPhysicalPath . DIRECTORY_SEPARATOR . $value, 145, 80, "none");

        $AG_thumb_checked = "";
        if ($ag_XML_thumb == $value) {
            $AG_thumb_checked = " CHECKED";
        }

        $ag_preview_content.='
     <div class="AG_border_color AG_border_width AG_item_wrapper">
   <a href="' . $ag_itemURL . $value . '" class="AG_fileLink AG_item_link" title="' . $value . '">
         <div style="display:block; text-align:center;" class="AG_item_img_wrapper">
         <img src="' . JURI::root() . 'administrator/components/com_admirorgallery/assets/thumbs/' . $value . '" class="ag_imgThumb" />
         </div>
   </a>


After changes it should look like:

Code:
        //agHelper::ag_createThumb(JPATH_SITE . $ag_itemURL . $value, $thumbsFolderPhysicalPath . DIRECTORY_SEPARATOR . $value, 145, 80, "none");

        $AG_thumb_checked = "";
        if ($ag_XML_thumb == $value) {
            $AG_thumb_checked = " CHECKED";
        }

        $ag_preview_content.='
     <div class="AG_border_color AG_border_width AG_item_wrapper">
   <a href="' . $ag_itemURL . $value . '" class="AG_fileLink AG_item_link" title="' . $value . '">
         <div style="display:block; text-align:center;" class="AG_item_img_wrapper">
         <img height="80" width="145" src="' . JURI::root() . $ag_itemURL . $value . '" class="ag_imgThumb" />
         </div>
   </a>


It will take longer to load the images, but they will load :)

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
 Post subject: Re: Image manager issues
PostPosted: Thu Mar 07, 2013 8:31 pm 
Offline

Joined: Tue Feb 19, 2013 9:04 pm
Posts: 4
Hi,

Thanks a lot for the reply

Your fixes worked, however I am now getting this error

http://prntscr.com/vdx3d

so I cannot save after I re order the files


Top
 Profile  
 
 Post subject: Re: Image manager issues
PostPosted: Thu Mar 07, 2013 8:31 pm 
Top  
 Post subject: Re: Image manager issues
PostPosted: Thu Mar 07, 2013 10:23 pm 
Offline
Developer
Developer
User avatar

Joined: Sat Aug 14, 2010 9:31 pm
Posts: 1241
Location: Novi Sad, Serbia
I don't think this has anything to do with Admiror Gallery because Admiror Gallery doesn't use mySql for storing data.

We use XML files for storing data.

It looks to me like some module is making this error.

_________________
Help Admiror Gallery become even better,
give us a review on JED


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

 


All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

This is the official Admiror Joomla! Community Forum. You are welcome to join the Admiror Joomla! Community. All Admiror Joomla! Extensions Users, Joomla! Developers, PHP or mySQL Developers are welcome to support & contribute to Admiror Joomla! Projects.

Joomla! is a free and open source content management system (CMS) for publishing content on the World Wide Web and intranets. With a vibrant volunteer community, user-friendly features and plenty of power, Joomla is perfect for your website!

Joomla! is written in PHP, uses object-oriented programming (OOP) techniques and software patterns, stores data in a MySQL database, and includes features such as page caching, RSS feeds, printable versions of pages, news flashes, blogs, polls, search, and support for language internationalization.

Joomla! is the property of Open Source Matters, Inc. All rights reserved. Read more about Joomla! at http://www.joomla.org/.


Protected by Anti-Spam ACP Powered by phpBB® Forum Software © phpBB Group